
Yiming Qiu 

yiming.qiu@nist.gov 

4/2016 



  1 

Easy Start 

Powder Sample ................................... 2 

Single Crystal Sample ......................... 3 

Single Crystal Diffuse Scattering ........ 6 

File Menu 

File Type ............................................. 7 

File Tools ............................................ 7 

Convert DCS Files to SPE Files ......... 7 

Patch DCS Files .................................. 8 

Plot Single Crystal Alignment Files ... 9 

Save Volume Data .............................. 9 

Save Slice Data ................................. 10 

Save Cut Data ................................... 10 

Save Projection ................................. 10 

Execute Script File ............................ 10 

Parameters Menu 

Save and Load Parameters ................ 12 

Change Self-Shielding Factor ........... 12 

Change Smoothing Kernel ................ 12 

Change Binning Threshold ............... 13 

Change Empty Can Subtraction Tolerance 

Value ................................................. 13 

Change Detector Offset Angle .......... 13 

Change WAND Incident Wavelength13 

Change MACS Detector Efficiency .. 13 

Background Menu 

Load Empty Can File(s) .................... 13 

Load Detector Background File(s).... 14 

Load Time Channel Background File 14 

Load Dark Count File(s) ................... 14 

Set Overall Background Rate ............ 14 

Load Vanadium File(s) ..................... 15 

Mask Menu 

DCS Mask ......................................... 15 

Set Mask............................................ 15 

Plot Mask .......................................... 16 

Mask Bragg Peaks............................. 16 

Save and Read Mask File .................. 16 

Option Menu 

Instrument Geometry ........................ 17 

Intensity Type ................................... 17 

Binning Method ................................ 17 

Monitor Count ................................... 18 

Absorption Correction ...................... 19 

Viewing Axis Type ........................... 19 

Allow Extra Viewing Axis ................ 19 

Folding of Viewing Axis ................... 20 

Show Powder Line ............................ 20 

Elastic Peak Position Adjustment ..... 20 

Empty Can Tolerance Method .......... 20 

Allow Voronoi Diagram ................... 21 

Slice Plot Empty Grid Color ............. 21 

Plot Window Background Color ....... 22 

User Macro/Function/Procedure ....... 22 

Dark Angle Correction ...................... 22 

Show Dark Angle Trajectory ............ 22 

E-Dep. Detector Efficiency Correction23 

Hide Error Bar ................................... 23 

View Spurions ................................... 23 

Popup Menu 

Check Bitflip Error ............................ 24 

Preserve Negative 2theta Angle Value24 

Detector 2theta Correction ................ 24 

Allow Two Sets of Empty Can Files 24 

Lock Lattice Parameters .................... 24 

Check Lattice Parameters in Files ..... 25 

Window Menu 

Hiding Part of the Window ............... 25 

Close All Plot Windows .................... 25 

Load Data File 

Load Data .......................................... 25 

Add Data ........................................... 26 

Clear Data.......................................... 27 

Projection 

Sample Type...................................... 27 

Lattice Parameters ............................. 27 

Crystal Orientation ............................ 28 

Viewing Axes .................................... 28 

Energy Rebin ..................................... 29 

Calculate Projection .......................... 29 

Plotting and Fitting the Data 

Intensity Label ................................... 29 

Title & Legend Label ........................ 29 

2D Slice Plot ..................................... 30 

1D Cut ............................................... 31 

3D Volume Plot ................................ 31 

Fitting Data ....................................... 31 

Detector Trajectories 

Plot Trajectories ................................ 31  



  2 

Powder Sample 

1. Change the sample type to Powder. Select the data files, and press Load Data button. 
 

 
 

2. Choose the viewing axes, and press Calculate Projection button. 
 

 
 

3. Press Plot Slice button to view the color contour plot of the intensity over the chosen viewing axes, 

or Surf Slice to view the 3D surface plot.  
 

 
 

The plot will look like the following, which is a superfluid liquid He4 roton spectrum. 
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4. Choose the cutting axis, and press Plot Cut to plot the cut. 
 

 
 

The plot will look like the following. 
 

 
 

Single Crystal Sample 

1. Change the sample type to Single Crystal. Select the data files, and press Load Data button. 
 

 
 

2. Select the empty can files, then in Background menu, press Load Empty Can File(s). 
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3. Choose the Vanadium file, and in Background menu, press Load Vanadium File(s). 
 

 
 

Press Yes for empty can subtraction and Skip in the dialog window for Debye-Waller factor and 

absorption correction calculation of the vanadium sample.  
 

4. In the Mask->DCS Mask menu, mask the upper and lower detector banks. 
 

5. Enter the lattice parameters, crystal orientation, and the viewing axes, then press Calculate 

Projection button. Psi is the angle from ki to u, with counterclockwise being the positive direction. 
 

 
 

6. Choose the slice plane. Press Plot Slice button to view the color contour plot of the intensity over 

the slice plane, or Surf Slice to view the 3D surface plot.  
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The plot will look like the following. 
 

 
 

7. Choose the cutting axis and thickness over the other two axes, and press Plot Cut to plot the cut. 
 

 
 

The plot will look like the following. 
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Single Crystal Diffuse Scattering 

1. Change the sample type to Diffuse Scattering Single E and choose Elastic Peak as the energy range. 

Select the data files 20030415_095.dcs.gz to 20030417_035.dcs.gz, and press Load Data button. 
 

 
 

2. In the Mask->DCS Mask menu, mask the upper and lower detector banks. 
 

3. Enter the lattice parameters, crystal orientation, and the viewing axes, then press Calculate 

Projection button. Psi is the angle from ki to u of the first file, with counterclockwise being the 

positive direction. 
 

 
 

4. Press Plot Slice button to view the color contour plot of the intensity over the viewing axes, or Surf 

Slice to view the 3D surface plot.  
 

 
 

The plots will look like the following. 
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File Type 

dcs_mslice is designed to handle multiple instrument and file formats. To switch among file types, go 

to File->FileType menu. If specific tools for the chosen file type are available, they are included in 

File->FileTools menu. Please refer to Help->How to Add a New File Type for the procedures of 

adding a new file type to the dcs_mslice program. 

File Tools 

File->FileTools menu contains specific tools for the current file type. This menu will be insensitive if 

no tools are available. Details of several tools are described below. 

Convert DCS Files to SPE Files 

For DCS file type, Convert DCS Files to SPE Format button in the File->FileTools menu starts a 

stand-alone application to convert DCS files into ASCII SPE format which can be processed by 

MATLAB Mslice or other programs. 
 

 
 

Choose one or more DCS *.dcs or *.dcs.gz files in the DCS file directory, press Convert button to 

convert them into *.spe files. The converted files will have the same names as the DCS files except for 

the file extension and they are saved in the SPE file directory.  
 

To combine two or more DCS files, choose them in the DCS file directory, then press Combine 

button. The name of the combined SPE file can be specified in the save as: textbox. If no name is 

given, the default is 'combine.spe'. 
 

Overall background rate and Associated error are used to apply an overall background rate to all 

the detectors.  The background will be subtracted in Convert and Combine operations. 
 

Energy binning size is used to rebin the time channel to reduce the size of data. 
 

Load BG button is used to load background files, which will be subtracted in Convert and Combine 

operations. There are two types of backgrounds: empty can and detector dependent energy gain side 

background. The types can be changed in Option->BG File Type. Once the background file is loaded, 

they will stay in the memory until Clear BG button is pressed. The Clear BG button will be sensitive 

only when a background file has been loaded. Note that the empty can files are treated as powder type, 

i.e., no rotation angle information is stored. 
 

Load V button is used to load vanadium files, which will be used to calculate the detector efficiencies. 

If the empty can background data are present, they can be subtracted from the vanadium data. The 

http://mslice.isis.rl.ac.uk/
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detector efficiencies are divided from data in Convert and Combine operation. Once the vanadium 

file is loaded, the detector efficiencies will stay in the memory until Clear V button is pressed. The 

Clear V button will be sensitive only when a vanadium file has been loaded. 
 

Both background files and vanadium files are selected in the DCS file directory. 
 

Detectors can be masked in various ways in the Mask menu. Once set, the mask will stay in the 

memory until Mask->Clear the mask is pressed. 
 

The data files can be saved as either single crystal or powder sample by choosing the corresponding 

sample type in the Option->Sample Type menu. With the choice of powder sample, detectors with 

the same two theta angle will be combined. The default is powder. 
 

Detector configuration file (*.phx) can be created during file conversion by choosing the Yes option in 

Option->Create Detector File. The sample rotation angle information can also be saved in a file by 

choosing the Yes option in Option->Create Rotation Angle File. The default is No for both options. 
 

The other options in the option menu are the same as those in the mslice option menu. 

Patch DCS Files 

Use this tool in the File->FileTools menu to patch the wavelength info, comment, or A2 angle of a 

DCS file. It can also be used to salvage jumpy files if multiple .sht files have been created during data 

collection. 
 

 
 

To change the wavelength info in a DCS file, select the file in the DCS raw file directory first. The 

original wavelength info will appear in the center left column as shown in the above figure. Enter new 

values in the center right column, and click Patch button to save the patched file in the patched file 

directory. The name of the patched file will start with a letter which can be changed in the option 

menu. The comment in a DCS file can also be changed by setting the “Allow Patching Comments” 

option. If only the tsdmin value needs to be changed, set the “Patch Tsdmin and Rotate Time Channel 

Only” option. 
 

To patch the A2 (sample rotation) angle, set the “Patch A2 Only” option. If multiple files are selected, 

the same offset value calculated from the A2 value in the first file and the entered new A2 value will 

be applied to the other files. 
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To patch a jumpy file from .sht files, set the “Patch Jumpy File Only” option. Select the jumpy .dcs.gz 

file, and click Patch button. The .sht files need to be present in the raw file directory. 

Plot Single Crystal Alignment Files 

This is one tool specific for DCS, WAND, and MACS files. It allows one to easily plot the single 

crystal alignment files and fit the peak with a Gaussian function. The detector numbers corresponding 

to the Bragg peak need to be specified. The time channels can be all, elastic (time channels covering 

the whole elastic peak) or specified energy range. It also provides the capability of plotting 

temperature dependence of intensities in specified detectors and time channels. 
 

   
 

            
    

Save Volume Data 

File->Save Volume Data As menu allows you to save the current volume data either in a single 

multi-column ascii file, or into multiple slices. In the single ascii file, the first line is the label of each 

column of the data. In saving as multiple slices, x-slice means the slice is perpendicular to x axis, ie. 

yz planes, and y-slice and z-slice are perpendicular to y axis and z axis respectively. Once chosen a 

file name fname, the actual slice file names for x slices will be fname_x=###.ext, where ### is the x 

value for the slice, and ext is the file extension of the selected file format. The available file formats 

are described below, except for DAVE file. 
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Save Slice Data 

File->Save Slice Data As menu allows you to save the current slice data in four formats: DAVE file, 

SPE file, (intensity, err, x, y) 4-column ascii file, or (x, y, intensity, err) matrix file. The following is 

an example of the matrix file for a 3x4 matrix data. 
 

  3 4   ;nx  ny 
   

  0.2   ;xdat 

  0.4 

  0.5 
 

  -1   ;ydat 

  0 

  1 

  2 
 

0.10   0.22    0.33 ;intensity 

0.11   0.40    0.65 

0.12  -2.80   -1.20 

0.13    3.12    0.00 
 

                    0.01    0.02    0.04 ;error bar 

  0.02    0.10    0.11 

  0.02    0.75    0.02 

  0.03    0.25   -1.00 
   

The slice data are exactly the same as the data shown if Plot Slice button is pressed except that there is 

no smoothing of the data. -1 in the error bar signifies missing data in the grid. A filler of -1e20 is also 

used to represent the missing data intensity.  
 

An additional ascii format PSUTXT is implemented in the script file execution:  

   self->script,'save_slice',directory=directory,filename=filename,/psutxt 

          This format is intended to save the slice suitable for PSU data analysis.  

Save Cut Data 

File->Save Cut Data As menu allows you to save the current cut data in two formats: (x, y, yerr) 3-

column ascii file, or DAVE binary file. 
 

The cut data are exactly the same as the data shown if Plot Cut button is pressed. 

Save Projection 

File->Save Projection As menu allows you to save the whole projection data in a multi-column ascii 

text format. The first line is the label of each column of the data. 

Execute Script File 

A script file should contain executable IDL statements. The following is a list of operations that can 

be included in the script file. 
 

self->script,'load_parameter',directory=directory,filename=filename ;load parameter file 

self->script,'load_emptycan',directory=directory,filename=filename,combine=combine,$ 

          angwidth=angwidth       ;load empty can file 
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       ;The combine and angwidth keywords are used in the diffuse scattering. If combine is set,  

       ;files with orientation angle within angwidth will be combined. If angwidth is not supplied, 

       ;the default self.angwidth is used.  

self->script,'load_data',directory=directory,filename=filename,eief=eief ;load data file 

self->script,'calc_projection',temperature=temperature,dwu2=dwu2  ;calculate projection 

        ;The temperature keyword is used as the sample temperature for certain intensity types. 

        ;The dwu2 keyword is used for u2 in the Debye-Waller correction for certain intensity types.  

       ;The default value for dwu2 is 0.  

self->script,'save_cut',directory=directory,filename=filename,xye=xye,dave=dave 

           ;save cut to a file 

self->script,'save_slice',directory=directory,filename=filename,dave=dave,iexy=iexy,spe=spe,$ 

      xyie=xyie,smooth=smooth,filler=filler,psutxt=psutxt   ;save slice to a file 

      ;The smooth keyword is used for smoothing the data. The default value is 0. 

      ;The filler keyword is used to represent the empty grid data. The default value is -1e20. 

self->script,'save_volume',directory=directory,filename=filename,smooth=smooth,filler=filler,$ 

         slice=slice,iexy=iexy,spe=spe,xyie=xyie,psutxt=psutxt 

       ;Save volume to a single multi-column text file if slice keyword is not present. 

         ;Save volume as multiple slices when slice keyword is present: 

         ;slice=0, x slices (ie yz planes); slice=1, y slices (ie xz planes); slice=2, z slices (ie xy planes). 

         ;iexy, spe, xyie, and psutxt keywords are combined with slice keyword to specify the output file  

         ;format.   

self->script,'save_projection',directory=directory,filename=filename ;save projection to a file 

self->script,'keep_current_plot'      ;keep the current plot 

self->script,'plot_cut',overplot=overplot,title=title,legend=legend  ;plot the cut 

self->script,'plot_slice',surfplot=surfplot,title=title    ;plot the slice 

self->script,'plot_volume',title=title      ;plot the volume data 

self->script,'set_parameter',name=name,value=value   ;set parameter 

       ;The name keyword is a string or string array. 

        ;value is a number or array of numbers. value and name keywords must have the same size. 
 

In 'save_cut' script, set the xye keyword to save as a text file. In 'save_slice' script, set one of the psutxt, 

spe, iexy, and xyie keywords to save as a text file. The file formats are described in the save slice data 

section. 
 

In 'set_parameter' script, the names of the text box parameters are shown in the figures below. 
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Save and Load Parameters 

To save the current settings in the main window, click the Parameter-> Save Parameters button. A 

file selection window will pop up. The default extension of saved file is *.prm. If no file name is 

entered or selected, no action is taken. 
 

To load a previously saved parameter file, click the Parameter->Load Parameters button. A file 

selection window will pop up. All the parameters shown in the main window plus some options will 

be restored. However, previous data and projection are not loaded. 

Change Self-Shielding Factor 

The self-shielding factor is used in background subtraction according to the following equations: 
 

  I    =  I1-ssfactor*I2 , 

  dI  = √dI1
2 + (ssfactor ∗ dI2)2 . 

Change Smoothing Kernel 

The smooth kernel for smoothing the 2D slice data can be changed in the Parameter menu. The 

default kernel is [[0.1,0.2,0.1],[0.2,0.8,0.2],[0.1,0.2,0.1]]. An error will be displayed if the entered 

matrix is not symmetric. 
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Change Binning Threshold 

The binning threshold (f) is a factor that is used to remove bins that have too small number of data in 

them. Only bins that have at least f*NMAX number of data will be plotted. NMAX is the maximum 

number of data in a single bin. The default is f=0, which will include all data in the binning. This 

factor will be reset to 0 every time a new file is loaded. 

Change Empty Can Subtraction Tolerance Value 

The tolerance values are used for locating the corresponding empty can data during background 

subtraction. In diffuse scattering modes, the rotation angle is used to match the data. For MACS data, 

the energy, kidney angle, and A3 (single crystal only) need to be matched.  
 

There are two methods to find the match. One is to find the ones that are within the tolerance or the 

closest one, the other is to find the ones that are within the tolerance of the closest one. For example, if 

the sample data rotation angle is 2.1, and the empty can rotation angles are [1,2,3,4,5], and the 

tolerance is 1, then for the first method, the matched empty can angle will be 2 and 3 (within the 

tolerance); for the second method, the matched empty can angle will be 2 (closest) and 1 and 3 (within 

the tolerance of the closest). The empty can subtraction tolerance method can be chosen at the 

Option->Empty Can Subtraction Tolerance Method menu. 

Change Detector Offset Angle 

This menu item will only appear in WAND and MACS file type.  
 

The detector bank of WAND is movable. The default location of the detector bank is at an offset angle 

(the smallest angle of the detectors) of 11.236˚. Use this operation to change the offset angle. The 

offset angle will not be saved in a parameter file, and every time the program is started, the offset 

angle will be set to the default value.  
 

For MACS, the default offset value is 0. If by any chance the detector angles need to be offset, use 

this operation to achieve the adjustment. 

Change WAND Incident Wavelength 

This menu item will only appear in WAND file type. The default incident wavelength for WAND is 

1.46 Å. Use this operation to change the incident wavelength. The incident wavelength will not be 

saved in a parameter file, and every time the program is started, the incident wavelength will be set to 

the default value. 

Change MACS Detector Efficiency 

The detector efficiency values of the 20 spectroscopic detectors and 20 diffraction detectors are saved 

in the data file and available once the data are loaded. They can also be set by loading the vanadium 

file in Background->Load Vanadium File(s). The detector efficiency can also be manually changed 

in this operation. If the detector efficiencies are changed, and no vanadium file has been loaded, one 

needs to confirm not to overwrite the detector efficiency during file loading. (These values are 

actually inversely proportional to the detector efficiency, i.e., in the calculation, the intensity will be 

multiplied by these values.) 

Load Empty Can File(s) 

To load an empty can file, use the upper left file locator to select the empty can file(s). Then press the 

Background->Load Empty Can File(s) button.  The empty can data will stay in the memory until 
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the Background->Clear Background is pressed. The empty can data will be subtracted in projection 

calculation. The intensity (I) and error (dI) are calculated as follow: 
 

  I    =  I1-ssfactor*I2 , 

  dI  = √dI1
2 + (ssfactor ∗ dI2)2 , 

 

where ssfactor is the average self-shielding factor. In diffuse scattering mode, the background file data 

are accompanied by orientation angle information, and the background data within the specified 

tolerance or with the closest orientation angle are subtracted during projection calculation. In the other 

modes, the background files are combined into one angle even if the actual angles are different. 
 

For MACS data, the energy, kidney angle, and in single crystal mode the rotation angle a3, of the 

background file data needs to be matched. The background data are subtracted during projection 

calculation. 
 

The tolerance value can be changed in Parameter->Change Empty Can Subtraction Tolerance 

Value.  

Load Detector Background File(s) 

This operation calculates the supposedly flat background from the specified background files. The 

result is an array with the size of the number of detectors. An energy range will be asked, which is 

used to locate the flat background. An example will be using a very low temperature measurement and 

an energy range in the energy gain side, where no scattering would be expected. The background data 

will stay in the memory until Background->Clear Background is pressed. The background will be 

subtracted in projection calculation. 

Load Time Channel Background File(s) 

This operation calculates the background of certain time channels averaged over a given 2theta range 

from the specified background files. The result is an array with the size of the number of time 

channels in the given energy range. The energy range and two theta range will be asked, which are 

used to locate the background.  The background data will stay in the memory until Background-

>Clear Background is pressed. In projection calculation, the background in the relative time 

channels will subtracted from the data. 

Load Dark Count File(s) 

This operation loads a shutter closed dark count file. Use Background->Clear Background to clear 

it from the memory. This operation currently is only functional for DCS file type. If empty can data 

are present, the dark counts will be subtracted from them also. Dark count data and the overall 

background rate reside in the same memory. 

Set Overall Background Rate 

The Set Overall Background Rate button in the Background menu is used to input the overall 

background rate in counts/hour/detector. The value is then adjusted accordingly to be subtracted from 

DCS data in projection calculation. There is no error bar handling in this process. Use Background-

>Clear Background to clear it from the memory. This operation currently is only allowed for DCS 

file type. If empty can data are present, the overall background rate will be subtracted from them also. 
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Load Vanadium File(s) 

To calculate the detector efficiency factor of the spectrometer, first highlight the vanadium file using 

the upper left file locator, then press the Load Vanadium File(s) button in the Background menu.  
 

If the empty can data are present when this operation is carried out, they can be subtracted from the 

vanadium data in the first two sample types. The Debye-Waller factor will be calculated if the 

temperature is given. One can choose to skip this calculation. The absorption of the vanadium is taken 

into account if the dimensions of the annular vanadium sample are given. Press OK button without 

giving the dimensions will skip the absorption calculation. 
 

For file types other than MACS, the detector efficiency factor is calculated as proportional to the 

integrated intensity of the elastic peak in each detector. The detector efficiency factor is divided from 

the raw data every time the projection is calculated.  
 

For MACS, there are two types of vanadium files: kidney scan files and A5 scan files. The kidney 

scan files are suited for elastic data and the A5 scan files are suited for inelastic measurements. When 

one chooses to load the kidney scan vanadium files, the files doesn’t need to be actual vanadium 

measurement. Since the calculation is based on matching data in overlapping detectors, any data file 

with overlapping a4 angles for different detectors will work. The range of A4 to be excluded from the 

calculation needs to be provided to avoid the direct beam. The intensity factor could be either the 

average of the ratios of the overlapping intensity, or the ratio of the averaged intensities of the 

overlapping data. The symmetrization option is intended to make the counts of detectors with the 

same |A4| at positive and negative side equal to each other. This is necessary since sometimes there 

might be a break in the overlapping region due to the exclusion of lower angle A4s. When loading A5 

scan vanadium files, two files need to be loaded, each measured at a different kidney angle to 

compensate for the direct beam. The range of A4 to be excluded from the calculation needs to be 

provided. Once the vanadium files are loaded, the original detector efficiency info loaded from the 

data files will be replaced by the calculated values. Loading new data files will not replace the 

calculated values. (These values are actually inversely proportional to the detector efficiency, i.e., in 

the calculation, the intensity will be multiplied by these values.) 
 

Use Background->Clear Vanadium to clear the detector efficiency factor from memory. For MACS 

data, the original detector efficiency info loaded from the data file will be restored. 

DCS Mask 

There are three detector banks in the DCS instrument, each of which can be masked. There is also a 

Mask Negative Angle Detectors option to mask the small amount of detectors on the west side. As 

for all masking operation, the mask takes effect when projection is calculated. 

 

Mask set by detector angular range is stored separately, and will not be affected by DCS detector bank 

masking. 
 

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 

Set Mask 

To mask arbitrary detectors, one can either set mask or plot mask from the mask menu.  
 

To set mask by detector number (type 0), enter the detector number or detector range using “:” or “-” 

character. The detector number starts from 0. To set mask by angle (type 2), enter the masked angular 

range, using “:”, “>”, or “<” as the range character. “-” should be used only as the negative sign. 
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Mask set by detector angular range (type 2) is stored separately from the other masks. 

 

The mask takes effect when projection is calculated. Once set, the mask stays in the memory. To clear 

the mask, press Mask->Clear Mask button. Clearing the mask clears all types of detector masks. 
 

For MACS instrument, A3 angle can also be masked in the Mask->Set Mask->Mask A3 by Angle 

operation. The A3 mask and the detector mask are stored separately. Use Mask->Clear A3 Mask to 

clear the A3 mask. To only view the PTAI detector, set the Mask->Set Mask->View PTAI Only 

option. PTAI is the designated detector number for an intended Q value. This is most useful for 

viewing scans in triple-axis mode. Clearing detector mask or switching to other masking mode will 

clear this option. The View PTAI Only option can also be accessed by the toggle button next to Clear 

Data button.  
 

To mask data obstructed by sample equipment dark angle in diffuse scattering modes (single crystal 

mode for MACS), use the Mask->Set Mask->Mask Dark Angle… option. The dark angle position 

and dark angle width need to be specified. The dark angle position is with respect to the crystal 

orientation axis u, with counterclockwise rotation being positive. Click this option again to disable the 

dark angle mask. 

Plot Mask 

Plot mask will start an interactive masking tool. You can read the help information in that tool to learn 

how to use it to mask detectors. This function is available only when data are loaded.  
 

Plot mask by detector number (type 0) or by angle (type 1) will return the masked detector indices. 

For MACS, plot mask by angle will return the masked indices of the actual two-theta angles, not the 

indices of the 20 detectors. The mask takes effect when projection is calculated. 
 

Mask set by detector angular range is stored separately, and will not be affected by plotting mask. 
 

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 

Mask Bragg Peaks 

To automatically mask the detectors where the Bragg peaks occur, press the Mask->Set Mask-

>Mask Bragg Peaks menu button. An interactive plot mask window will appear to allow 

modifications. This function is available only when data are loaded. The mask takes effect when 

projection is calculated. This operation automatically clears the mask set by detector angular range. 
 

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 

Save and Read Mask File 

The detector masks can be saved in a text file by pressing the Save Mask File in the Mask menu. For 

type 0 and type 1 masking, the masked indices are saved. For type 2, the angular mask string is saved. 
 

The index numbers of detectors to be masked can also be read from a text file (type 0 and 1). The 

numbers should be separated by space or comma, and can be in multiple lines. The detector number 

starts from either 0 or 1. For type 2 mask file, the angular mask string is read from the file. The mask 

takes effect when projection is calculated. 
 

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 
 

For MACS instrument, both the detector and the A3 masks are saved or read. 
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Instrument Geometry 

There are two instrument geometries, Direct for fixed Ei instruments and Inverse for fixed Ef 

instruments. For a given instrument, this option may not be changeable. 
 

Tip: For MACS, even if the instrument is run at inverse geometry, to be able to view data measured at 

different Ef with the E-dependent detector efficiency correction on, the instrument geometry should be 

switched to direct. 

Intensity Type 

Use Option->View Intensity As button to choose the intensity type as one of the following: 
 

 

S(Q,omega)                           --- a factor of (ki/kf)4 is applied to the monitor normalized intensity; 

                                                    for MACS, a factor of (1/kf) is applied; 

Symmetrized S(Q,omega)   --- a factor of exp(-E/2kBT)*(ki/kf)4 is applied; 

                                                    for MACS, a factor of exp(-E/2kBT)*(1/kf) is applied; 

d2(sigma)/d(Omega)d(Ef)   --- a factor of (ki/kf)3 is applied ; 

Chi(Q,omega)                       --- a factor of [1-exp(-E/kBT)]*(ki/kf)4 is applied; 

                                                    for MACS, a factor of [1-exp(-E/kBT)]*(1/kf) is applied; 

GDOS                                    --- a factor of [1-exp(-E/kBT)](ki/kf)4 *E/Q2 is applied; 

VDOS                                    --- a factor of [1-exp(-E/kBT)](ki/kf)3 *E*sin(2θ)/(Qmax
4-Qmin

4) is  

  applied; 

J(Q,y)                                     --- the intensity is (ħQ/M )*S(Q,omega), and y = (M/ ħQ)*(E-ER), 

                                                    where M is the mass, and ER = (ħQ)2/(2M); 

Unadjusted by ki/kf factor  --- no ki/kf factor is applied to the monitor normalized intensity. 
 

The option E-Integrated Intensity in the Option->View Intensity As menu will result in the 

following calculation being carried out in plotting cuts and slices: 
 

  ΔE
 IΔ

I









, 

 

where  is the energy width for the corresponding time channels, and E  is the proper energy 

range, for example the energy thickness in a Q-cut, or the energy binning steps. A warning message 

will be displayed if this option is on when starting dcs_mslice program. 
 

For MACS files, use Option->View Intensity As->MACS Detector Choice menu to select among 

SPEC, DIFF, or SPEC+DIFF detectors for the intensities. The SPEC detectors are the spectroscopic 

detectors after the second vertical focusing analyzers, and the data contain energy information. The 

DIFF detectors are the diffraction detectors directly behind the first vertical focusing analyzers, and 

the data contain no energy information. The energy transfer is set to 0 for DIFF and SPEC+DIFF 

detectors during projection calculation. 

Binning Method 

Two binning methods, average and sum, can be chosen from the Option->Binning Method menu 

button. The average or sum of the intensities in each bin is calculated respectively in the two methods. 

The binning method is applied in rebinning time channel according to E Rebin Size for powder and 

single crystal mode, and rebinning data in displaying slices and cuts. 
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There are two options of averaging: arithmetic mean or weighted mean. For arithmetic mean, the 

mean value and the error bar is calculated as: 
 

 𝑥 =
∑ 𝑥𝑖
𝑛
𝑖

𝑛
 , 

   𝑑𝑥 =
√∑ 𝑑𝑥𝑖

2𝑛
𝑖

𝑛
 . 

 

For weighted mean, the mean value and the error bar is calculated as: 
 

  𝑥 =
∑ 𝑥𝑖𝑑𝑥𝑖

−2𝑛
𝑖

∑ 𝑑𝑥𝑖
−2𝑛

𝑖

 , 

  𝑑𝑥 = √
1

∑ 𝑑𝑥𝑖
−2𝑛

𝑖

 . 

 

Note that the weighted mean currently is not implemented in the external binning library. The external 

binning library needs to be disabled before the weighted mean can take into effect. For the time 

channel rebinning, only the arithmetic mean is used for averaging.  
     

Option->Binning Method->Constant Intervals menu provides the option of creating binned data at 

constant interval. If the option is not set, then averaged values will be the output. 
 

Option->Binning Method->Use External Binning Library menu provides the option of using or 

disabling the external binning library written in C. If enabled, the external binning library is used 

when binning steps are specified. Using the external binning library is much faster than without. 

However, you can disable it if the external library is not properly installed. 
 

For data with a lot of zero intensities, binning with arithmetic mean or sum method could lead to an 

exaggeration of error bars if each zero intensity is properly assigned a statistical nonzero error bar. 

Option->Binning Method->Check Zero Intensities menu provides the option of checking the zero 

intensities. If this option is enabled, during binning, the error bars of all zero intensities will be set to 

zero. After the binning, data with zero error bars will be reassigned the minimum error bar of the zero 

intensities prior to the binning. Note that combining data during file loading will use the same check if 

the option is enabled. 

Monitor Count 

The option Option->Monitor Count only applies to DCS and MACS file type.  
 

For DCS, there are two options to calculate the monitor count: sum of beam monitor counts or the 

integrated intensity of the beam monitor counts after fitted by a Gaussian. The monitor count is used 

to normalize data in loading DCS files. The monitor type can be selected by Option->Monitor 

Count->Monitor Choice. BM1 is the monitor at the guide exit, and FC0 is the upstream monitor 

before the choppers. BM1 is the default monitor, and only when it is selected will sum and integrated 

intensity option matter. 
 

For MACS, the two options for monitor count are automatic and specified. In automatic monitor count, 

the monitor count of the first file is used to normalize the intensities. A specific monitor count value 

can also be specified. The default specified monitor count is 1e6 if the monitor type is monitor and 30 

seconds if the monitor type is time. The monitor count option can also be set in the file frame below 

the sample type choice. The monitor type can be selected by Option->Monitor Count->Monitor 

Choice. The monitor lambda/2 correction option is for the higher order neutron correction of the 

monitor counts. It is applied only when no CFX filter is used. The CFX info in the data file might not 
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have been implemented. If that is the case, the data file will always indicate that no CFX filter is being 

used. The monitor lambda/2 correction is applied during projection calculation. 

Absorption Correction 

Absorption corrections for cylindrical, annular, spherical, and flat plate sample geometries are 

implemented in the program. Go to Option->Absorption Correction menu to set the option. The 

absorption correction factor for every angle and energy is calculated using specified number of 

uniform sampling points on the sample cross section. If interpolation is selected, instead of calculating 

the correction for all detectors and all time channels, which is time consuming, interpolation from at 

most 100 angles and at most 100 energies will be used. The correction is for equatorial scattering only. 

The effect of DCS radial collimator is not taken into account in the calculation. Below is a sketch of 

the flat plate sample, the angle as shown in the figure is positive. 
 

 

Viewing Axis Type 

For single crystal and diffuse scattering type, there are two options of viewing axis: orthogonal and 

arbitrary. They can be set in Option->Viewing Axis. If orthogonal option is chosen, the viewing axes 

given must be orthogonal to each other.  

Allow Extra Viewing Axis 

In single crystal and diffuse scattering modes, by default only two viewing axes plus the energy 

(except for diffuse scattering single energy) are available for projection. To have a third viewing axis, 

set Option->Viewing Axis->Allow Extra Viewing Axis on. The orthogonality of the viewing axes 

follows the Option->Viewing Axis setting. The projection needs to be recalculated. 
 

For MACS and WAND, there’s no out-of-plane projection component, however, the temperature can 

be added as the extra viewing axis by setting Option->Viewing Axis->Allow Temperature as Extra 

Viewing Axis on for WAND, and the temperature and/or magnetic field and/or a third specified 

parameter can be added as the extra viewing axes by setting the Option->Viewing Axis-> Extra 

Viewing Axis options for MACS. The data files (not the background files) need to be reloaded if the 

option is switched on. One can also choose to view among sample, control, and set point temperatures 

for MACS. The option to average the temperature of each file is to avoid the temperature fluctuations. 
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Folding of Viewing Axis 

There are two types of folding, mirror reflection and symmetry rotation, which can be selected in 

Option->Folding Type menu.  
 

In the mirror reflection type, the folding is around a folding center. The folding center and the folding 

direction are specified next to the Fold button in the projection window. The auto folding direction is 

to the side with larger range. Multiple folding centers can be specified in the text box separated by 

space or comma. Clicking on the direction droplist with multiple folding centers specified will bring 

up a dialog window for the multiple folding directions. The folding is done in the same order that the 

centers are specified. To fold into both directions, set the Option->Folding Type->Mirror 

Reflection Type->Fold to Both Sides option. In this option, only one folding center is allowed for 

each viewing axis. 
 

  
 

In the symmetry rotation type, the Q values are rotated by an angle of 360/n_fold incrementally if 

necessary in order to reach the first symmetric section or the first quadrant of the viewing coordinate 

system. N_fold is an integer specified in the n-fold text box next to the Fold button. By default, the 

first symmetric section starts from u1 viewing axis, but can be changed by Option->Folding Type-

>Symmetry Rotation Type->First Symmetric Section Starting Vector->Specify option. To view 

the full 360 scattering map based on the symmetry rotation of the existing data, set the Option-

>Folding Type->Symmetry Rotation Type->Expand to 360 option. The full data set is rotated and 

pasted one or several times to cover the full 360 map. 
 

The projection needs to be recalculated if any of the folding selections is changed.  

Show Powder Line 

In diffuse scattering mode, Al, Cu, stainless steel, or specified powder lines can be overplotted to the 

intensity contour plots or detector trajectories (when the viewing axes are x and y axis). To do this, 

select the Al, Cu, or Stainless Steel option in Option->Show Powder Line menu. Arbitrary Q values 

can also be specified.  The projection needs to be recalculated to have the option in effect.  

Elastic Peak Position Adjustment 

The elastic peak position adjustment operation in Option->Elastic Peak Position Adjustment rotates 

the data so that the maximum intensity(Automatic) or the time channel of specified energy(Specify) 

will be shifted to E=0. The energy values will not be changed. If Check the First File Only option is 

on, only the first file will be examined for how many time channels need to be shifted. After changing 

this option, you need to reload the data files. 

Empty Can Subtraction Tolerance Method 

There are two ways to locate the corresponding empty can data during background subtraction. The 

first method is to find the ones that are within the specified tolerance or the closest one. The second is 
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to find the ones that are within the specified tolerance of the closest one. For the first method, if no 

empty can data is within the specified tolerance, and the closest one is used instead, a warning 

message will be displayed. 
 

If the empty can files and the sample data cover the same range, the two methods usually will give the 

same subtraction result. However, if the empty can data and the sample data cover different range, the 

two methods usually will yield different results. For example, if the empty can are measured at 

rotation angles of [11˚̊, 12˚, 13˚, 14˚], and the sample at [1˚, 2˚, 3˚, 4˚], and the tolerance value is 

1˚. For the first method (within tolerance or closest), the empty can data for the 1˚ data will be the 

11˚one, while for the second method (within tolerance of the closest), the empty can data will be the 

average of 11˚ and 12˚. 
  

The tolerance values can be changed in Parameter->Change Empty Can Subtraction Tolerance 

Value menu. 

Allow Voronoi Diagram 

When plotting a contour slice plot, mslice usually rebins the data to a regular grid format and displays 

them as connected polygons. The data can also be displayed as Voronoi diagrams without rebinning. 

The plots with Voronoi diagrams are therefore more natural looking and preserve the distribution 

density of the raw data. However, using Voronoi diagrams is much slower than dipalying the rebinned 

data. Below are the examples of a data set drawn with Voroni diagrams and with rebinned regular grid. 
 

 

Slice Plot Empty Grid Color 

Two options are available for rendering the empty grid in a contour slice plot: none or average of 

neighbors. Choosing none will leave an empty spot on the plot while using average of neighbors will 

reduce the number of empty spots. Below are the same plot using these two different options. 
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Plot Window Background Color 

The background color of the plot windows can be either black or white, selected in Option->Plot 

Window Background Color. 

User Macro/Function/Procedure 

To interact with the projected data, use the Option->User Macro/Function/Procedure menu. Either 

multiple strings of command macros or a string of call to user defined IDL function or procedure can 

be specified. 
 

The user macro should be executable IDL statements. Multiple statements can be in a single line 

separated by “&”. The user function and user procedure can be defined in any way. Only the call to 

the function or procedure needs to be entered in the menu dialog window. A partial list of the internal 

variables is shown in the dialog window. The array dimensions of the variables should not be altered. 

The user functions are executed during projection calculation. 
 

Here are some of the available variables: 

   qty  --- intensity. 

   err --- error bar. 

   eief --- Ei for direct geometry(self.instrgeom=0) and Ef for inverse geometry(self.instrgeom=1). 

   psi --- psi angles, for MACS, it is 90˚- A3. 

   Qv --- wave vector projected onto the viewing axes, in corresponding reciprocal lattice unit. 

   en --- energy transfer. 

   Ei --- MACS only. 

   Ef --- MACS only. 

   kidney --- MACS only, the kidney angle. 

   det_tt --- detector 2θ angle. 
 

Tip 1: Specifying the user function after the projection has been calculated will enable the array 

dimensions of the available variables being shown. The projection needs to be recalculated after the 

user function is entered. 
 

Tip 2: To do a model calculation, generate qty and err so that they have the same array dimensions as 

Q in powder mode, or an array dimension of [D2, D3, …] in single crystal mode, where Qv has a 

dimension of [D1, D2, D3, …]. 

Dark Angle Correction 

In diffuse scattering measurement, if the incident neutron intensity is affected by the dark angle of the 

cryostat or magnet, a simple dark angle correction can be applied by assuming a constant scattering 

cross section (such as elastic incoherent scattering or vanadium) in specified energy transfer and two 

theta range. This option is in Option->Dark Angle Correction. You can choose the same data files 

for this purpose. The projection needs to be calculated to have the option in effect. After projection 

calculation, the overall intensity factor for each corresponding file is given the value of Imax/I, where 

I is the total neutron counts in the specified E and two theta range.  

Show Dark Angle Trajectory 

In diffuse scattering modes (single crystal mode for MACS), use this option to show the trajectory of 

a dark angle of a cryostat in experiment planning. With this option on, when you calculate the 
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projections, in the dialog window for Psi range, there are entries for the dark angle position and dark 

angle width. The dark angle position is with respect to the crystal orientation axis u, with 

counterclockwise rotation being positive. The plot shows an example where the dark angle is along v 

axis. 
 

  
 

E-Dependent Detector Efficiency Correction 

The energy dependent detector efficiency correction to the intensity can be applied to the data in 

projection calculation. To set this option on and off, press the Option->E-Dependent Detector 

Efficiency Correction button. The default option is on for DCS, and off for the other file types. This 

option is only available if the instrument is in direct geometry. When the option is turned on, the 

detector thickness and helium-3 pressure need to be confirmed. The default values for DCS detectors 

are 1 cm and 6 atm, and the default values for MACS detectors are 3.773 cm and 3 atm. 
 

Tip: For MACS, even if the instrument is run at inverse geometry, to be able to view data measured at 

different Ef with the E-dependent detector efficiency correction on, the instrument geometry should be 

switched to direct. 

Hide Error Bar 

Choose Option->Hide Error Bar to prevent the error bars been passed to the plots (cuts, slices, and 

volume plots). However, the error bar will still be present in fitting the data. 

View Spurions 

Option-> View Spurions->View Spurion Caused by Detector option will calculate spurious 

scatterings by the detector wall of all elastic signals. If spurion exists, the program will use the current 

settings to plot a slice. This option is only available to direct geometry time-of-flight instruments, after 

data loaded and projection calculated. 
 

Option->View Spurions->View Spurion Caused by Gas Recoil option will calculate gas recoil 

scatterings from several type of exchange gas in the sample area. There are two options for the 

calculated S(Q, omega): T1-T2 or S(Q,omega,T). If T1-T2 is chosen, and T2 is not present, then 

S(Q,omega) of T1 is calculated. If S(Q,omega,T) is chosen, the temperature range is [T1, T2]. In 

single crystal mode, the reciprocal space projection is calculated using the parameters in mslice. Gas 

recoil simulation option is only available to MACS. 
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Check Bitflip Error 

Right-click to the left of Load Data button to show the popup menu and this option. Use this option 

to enable or disable the bitflip error checking during DCS data file loading. This option is only 

available for DCS file type. 
 

 
 

Preserve Negative 2theta Angle Value 

Right-click to the left of Load Data button to show the popup menu and this option. In powder mode, 

after the projection is calculated, only the absolute values of the 2theta angles are saved, unless the 

Preserve Negative 2theta Angle Value option is turned on. Except for MACS data, the projection 

needs to be recalculated to have the new option in effect. 

Detector 2theta Correction 

Right-click to the left of Load Data button to show the popup menu and this option. Use this option 

to enable or disable the 2theta correction due to the length of the detectors or some other reasons. This 

option may not be available for some instruments. 

Allow Two Sets of Empty Can Files 

Right-click to the left of Load Data button to show the popup menu and this option. Use this option 

to allow or disallow two sets of empty can files. If two sets are allowed, the empty can subtraction is 

as follows: 
 

  I   =   Isample - ssfactor*(factor1*Iemptycan1 + factor2*Iemptycan2), 
 

where ssfactor is the self-shielding factor, and factor1 and factor2 are extra factors that can be changed 

in  Parameter->Change 2-Set Empty Can Factors. The handling of the additional set of empty can 

files is the same as that of the first set. 

Lock Lattice Parameters and Crystal Orientation Axes 

Right-click to the left of Load Data button to show the popup menu and this option. This option will 

only appear in the MACS file type. If this option is set, loading MACS files will not automatically 
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enter the lattice parameters and scattering plane axes information from the file to the projection 

window. 

Check Lattice Parameters and Crystal Orientation Axes in Files 

Right-click to the left of Load Data button to show the popup menu and this option. This option will 

only appear in the MACS file type. If this option is set (default), while loading multiple MACS files, 

the program will automatically check the lattice parameters and crystal orientation axes info in the 

files to see if the files are consistent with each other. An error will occur if they are not consistent. To 

bypass the check, simply disable this option. 

Hiding Part of the Window 

The projection and the display frame of the window can be hidden by using the corresponding option 

in Window menu. This can be quite useful if the size of the window is larger than the screen. The 

following snapshot is an example. 
 

 
 

Close All Plot Windows 

To close all plot windows, simply press Window->Close All Plot Windows button. 

Load Data 

To load data files, use the top left file locator to select one or more files. Press Load Data button to 

load the data. An error will be displayed if no file is highlighted. For DCS data, the data will be 

normalized by the monitor counts of beam monitor 1 if shutter is open. For MACS data, the data will 

be normalized by the monitor counts in the projection calculation. 
 

For powder and single crystal sample type, the files will be combined. For diffuse scattering sample 

type, files are not combined, and energy range needs to be specified beforehand. For file types other 

than DCS, weights are required for proper data summation. 
 

The loaded data will not be modified by the program until new data file is loaded or added, or the 

sample type is changed to or from diffuse scattering types. Press Clear Data button to remove the 
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data from memory. 
 

 
 

For DCS data, on very rare occasions a warning message of “jumpy” file will appear. The “jumpy” 

data are due to electronic noise of the data acquisition system. Please discard these files after they are 

confirmed, or patch them if .sht files have been created during data collection. The intensity plotted 

against the detector number will look like: 
 

 
 

Tip 1: For supported file types, move the cursor over the highlighted files and right click to view the 

file information such as comment, wavelength, temperature, etc. 
 

Tip 2: Move the cursor to the left of the Load Data button and right click to access the extra options 

in the popup menu and view a list of the current settings of parameters. 
 

Tip 3: If the computer can access internet ftp sites, the NCNR data ftp site will be shown as a separate 

drive in windows platform, or a directory named “NCNR_ftp” in the root directory in unix platforms. 

You can also use the copy ftp files tool in the file tools menu to download files from the NCNR ftp 

server. If the ftp directory doesn’t appear, set the working directory to a writeable directory from the 

menu Parameter->Set Working Directory, which ensures that the temporary ftp files can be 

properly buffered. 

Add Data 

The Add Data button will be activated when data has been loaded.  
 

Select the data files to be added by the upper left file locator. Then press the Add Data button. An 

error will be displayed if the file selected and the existing data are of different type. The criteria for 

DCS files are wavelength, master speed, speed ratio, resolution mode, and tsdmin. 
 

For powder and single crystal data, the data are added to existing data; for diffuse scattering sample 

types, the data are appended to the existing data. The algorithm for computing added intensity (I) and 

error (dI) with weights (W) taken into account is as follows: 
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  I3     = (I1*W1+I2*W2)/(W1+W2), 

  dI3   = √(dI1 ∗ W1)2 + (dI2 ∗ W2)2/(W1 +W2), 
  W3   = W1+W2. 

Clear Data 

Press Clear Data to clear from memory the loaded data and calculated projection data if existed. This 

operation is useful in planning experiments. 

Sample Type 

There are four sample types (more accurately modes of operation): powder, single crystal, diffuse 

scattering singe E, and diffuse scattering multiple E. 
 

For powder mode, two viewing axes need to be specified. In the projection calculation, detectors with 

the same two-theta angle are combined. The data is plotted as 2D intensity color map on the plane 

defined by the viewing axes.  The data can also be cut along one of the two viewing axes with 

restrictions on the other axis, and plotted as 1d plot. 
 

For single crystal and diffuse scattering modes, lattice parameters, crystal orientation, and viewing 

axes need to be given to enable proper projection calculation.  By default two viewing axes are 

available. To enable a third viewing axis, check Option->Allow Extra Viewing Axis. Except for 

diffuse scattering single E mode, the energy is also present as one axis. The data is plotted as 2D 

intensity color map on the plane defined by two of the axes (including the viewing axes and the 

energy if available). The other axes are used to restrict the slice range. The data can also be cut along 

one of the viewing axes with restrictions on the other axes, and plotted as a 1d plot. 
 

For single crystal mode, the specified psi value is applied to all files, while in the diffuse scattering 

modes the specified psi value only corresponds to the first file. Single crystal mode, where all files 

are treated as having the same rotation angle, is actually a special case of the diffuse scattering 

multiple E mode. 
 

The difference between diffuse scattering single E mode and multiple E mode is the treatment of the 

energy dimension. In single E mode, data within the specified energy range are combined to a single 

energy to save computer memory, while in multiple E mode, the data are not combined, which could 

sometimes lead to memory problem. If error occurs due to lack of computer memory, the solution is to 

reduce the specified energy range, increase the E-rebin size, or switch to single E mode. 
 

When the sample type is changed, the projection data is cleared and need to be recalculated before any 

plots can be made. The raw data is still stored in the memory if the change is between powder and 

single crystal type. 

Lattice Parameters 

For single crystal and diffuse scattering sample types, the direct lattice parameters of the unit cell  are 

specified by a, b, c, , , and .   is the angle between b and c,  is the angle between c and a, and  

is the angle between a and b. An error will be displayed during projection calculation if any one of the 

six lattice parameters is missing. 
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Crystal Orientation 

For single crystal and diffuse scattering sample types, the crystal orientation with respect to the 

spectrometer is defined by two reciprocal crystal axes (u & v) in the principal scattering plane of the 

spectrometer and one angle (Psi), which uniquely identifies the rotation of the crystal in this plane.   
 

 
 

(ux, uy, uz) and (vx, vy, vz) specifies the two reciprocal crystal axes. u × v should point to the 

vertically upward direction. Psi is the angle between u and ki, and is positive if ki × u is pointing to 

the vertically upward direction.  For DCS file type, it should be the same as DCS A2 angle if A2 is set 

to 0˚ when ki is parallel to u. For diffuse scattering, Psi is the angle for the first file. 
 

For MACS file type, since the sample rotation angle A3 is saved in the data file, the Psi text box in the 

projection window is instead used for the A3 offset angle. The actual Psi angle is 90˚-A3. 

  

An error will be displayed in projection calculation if any value of u, v, or Psi is not set. 

Viewing Axes 

Powder 
 

The viewing axes for powder are two axes out of (Energy, |Q|, 2Theta, and Det Group Number). They 

can be specified from the droplists. The labels of the viewing axes are used as corresponding axes 

titles in the 2d plots. The Most commonly used set of viewing axes for powder sample is u1=|Q| and 

u2=Energy. 
 
 

Single Crystal and Diffuse Scattering 
 

The viewing axes for single crystal and diffuse scattering are wave vector directions. They must be 

orthogonal if the orthogonal option is chosen for the viewing axis type. An example is: 
 

  u1 = [1 0 0] ;a* 

  u2 = [0 1 0] ;b* 
 

An error message will be displayed in projection calculation if any value of the viewing axes is not 

given or the axes are not orthogonal when required. 

 

The viewing axes can be folded based on the folding types. In the mirror reflection type, the folding is 

around a folding center. The auto folding direction is to the side with larger range. Multiple folding 

centers can be specified in the text box separated by space or comma. Clicking on the direction 

droplist with multiple folding centers specified will bring up a dialog window for the multiple folding 
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directions. The folding is done in the same order that the centers are specified. In the symmetry 

rotation type, the Q values are rotated by an angle of 360/n_fold incrementally if necessary in order to 

reach the first quadrant of the viewing coordinate system. N_fold is an integer specified in the n-fold 

text box. The projection needs to be recalculated if any of the folding selections is changed. 

Energy Rebin 

To reduce the amount of data being processed and plotted, the raw data can be rebinned in the 

projection calculation for powder, single crystal, and diffuse scattering multiple E modes. Time 

channels are binned according to the size specified in the E Rebin Size textbox. No action is taken if 

the E rebin size is less than one or absent. The rebinning can be either average or sum according to the 

specified binning method. In powder and single crystal modes, the raw data is not affected by the 

rebinning, therefore changing the rebin size requires only the projection to be recalculated.  In diffuse 

scattering multiple E mode, the raw data are rebinned, therefore changing the rebin size requires 

reloading the data. 

Calculate Projection 

Press Calculate Projections button to project the raw data into viewing axes. Detector masks and 

detector efficiency factors are applied if they are present. The background will also be subtracted if 

they have been previously loaded. Intensity data are also rebinned if E rebin size is greater than 1 for 

powder and single crystal modes. The intensity will be calculated as one of several options chosen in 

Option->View Intensity As menu. Energy dependent detector efficiency will be calculated if the 

option is set. Absorption correction factors will be calculated and multiplied to the intensity if so 

chosen. User function will also be executed if specified. The projected data and the raw data are stored 

differently, i.e., the raw data are not changed by this calculation. If no data has been loaded, the 

program will prompt for incident neutron energy Ei to calculate detector trajectories. 
 

For powder mode, detectors with the same 2theta angle will be combined.  
 

For diffuse scattering modes, data with the same sample orientation angles will be combined. 
 

For single crystal and diffuse scattering modes, an error message will be displayed if any value of the 

lattice parameter, crystal orientation, and viewing axes is not given, or if the viewing axes are not 

orthogonal when required. 
 

Tip: For NXSPE file type, clearing data after loading an existing data file will save the detector 

information, which allows for the projection calculation. 

Intensity Label 

The intensity label is used as the axis title for intensity in plots. If not given, the default is Intensity. 

IDL formatting codes are supported. 

Title & Legend Labels 

The title label is used as title in plots. It is set to the comment of a data file after the file is loaded. If 

the comment ends with “T=”, the temperature set point will be automatically appended to the title 

label. 
 

The legend label is used as the legend in plotting 1D cuts. It is set to the last word of the comment of 

the data file after it is loaded, or various pieces of information such as temperature in the comment.  
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The plot title and legend can be easily modified in the plot window. IDL formatting codes are 

supported for the title and legend labels. 
 

Tip: To prevent the title and legend labels from being updated after loading a data file, click the lock 

image button next to the title legend. Click it again to allow the title and legend labels to be reset. 

2D Slice Plot 

The intensity data projected into two viewing axes can be plotted as color contour plot by pressing the 

Plot Slice button. 
 

The x and y axes are chosen from the x and y droplists. In Single Crystal and Diffuse Scattering 

modes, the droplist includes the viewing axes and the energy and temperature if available. The axes 

left in the droplist can be used to further define the thickness of the slice. 
 

Data can be rebinned by specifying the x and/or y step.  If not specified, the default binning size is 

1000 except for energy data. The binning algorithm is as follows: a grid of bins of size xstep x ystep is 

constructed with the lower left corner at (xmin-xstep/2, ymin-ystep/2) and not exceeding 

xmax+xstep/2 along x and ymax+ystep/2 along y. The x and y values for each bin are calculated by 

taking the average of the x and y values of all the data in that bin, and the intensity is the average or 

sum of all the data in that bin according to the specified binning method. The limits are inclusive to 

the left and exclusive to the right. 
 

The grid can be smoothed by choosing a nonzero Smoothing level. The smoothing is done by 

convoluting the rebinned data with a smoothing kernel. The default smoothing kernel is  
 

  0.1   0.2   0.1 

  0.2   0.8   0.2 

  0.1   0.2   0.1 . 
 

The kernel can be changed  in the Parameter menu. 
 

The color map of the contour plot can be chosen from the color map droplist. The names are the same 

as the predefined IDL color table names.  
 

Two types of shading are available: Flat and Gouraud. 

Flat: The color has a constant intensity for each face of the surface, based on the normal vector.  

Gouraud: The colors are interpolated between vertices, and then along scan lines from each of the 

edge intensities.  
 

The 2D data can also be plotted as color surface plots by pressing the Surf Slice button. 
 

Tip 1: Specify the horizontal and vertical range to reduce the amount of data and speed up the plotting. 
 

Tip 2: If the energy step is not specified, the original energies corresponding to the time channels are 

used. This will prevent the energy values from being changed by the binning process. 
 

Tip 3: For a large dataset, the binning will usually be much faster with the steps specified. 
 

Tip 4: In the plot window, right click over an object to change its properties. 
 

Tip 5: Leave both the horizontal and vertical step blank to plot the slice using Voronoi diagrams. The 

plot is more natural but much slower than rebinned regular grid plot. The Allow Voronoi Diagram 

option needs to be set to Yes in the option menu. 
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1D Cut 

Cuts can be made along one of the viewing axes with integration over the other one or two viewing 

axes. Use along droplist to select the x axis, and y droplist to select the y axis. The plotted data are the 

average or summed values over the integrated volume according to the specified binning method. 
 

X and y range, integration volume (thickness) can be specified by the from: and to: textboxes. Data 

can also be rebinned by specifying the cut step. The x-range is divided into bins of length step starting 

at xmin-step/2 and not exceeding xmax+step/2.  The x and y value for each bin is calculated by taking 

the simple average of the x and y values of all data in that bin, where the limits are inclusive to the left 

and exclusive to the right. 
 

Plot symbols can be specified by the color, symbol style, and line style droplists. White color will be 

switched to black when the figure is printed or saved as a file. Press Plot Cut to plot the cut in the 

current plot window, or press Oplot Cut to overplot the cut in the current plot window.  
 

The cut data can also be sent to the Peak Analysis (PAN) program for fitting. To do this, simply press 

the Fit button.  
 

Tip 1: If the cut is along energy and the step is not specified, the original energies corresponding to 

the time channels are used. This will prevent the energy values from being changed by the binning 

process. 
 

Tip 2: For a large dataset, the binning will usually be much faster with the step specified. 
 

Tip 3: In the plot window, right click over an object to change its properties. 

3D Volume Plot 

A volume plot can be made if the number of viewing axes (including the energy and temperature if 

available) is more than two. Proper steps need to be specified to achieve the ideal result. There are two 

interpolation methods: nearest neighbor and trilinear. The trilinear method gives a smoother look, but 

slower in rendering. 
 

Tip 1: In the plot window, right click over an object to change its properties. 
 

Tip 2: In the plot window, when slicing a volume, use the keyboard arrow keys to move step by step. 

Fitting Data 

Both the slice data and cut data can be sent to PAN program for fitting by pressing the Fit button. 

Plot Trajectories 

The Plot Trajectories button is insensitive until projection is calculated. The projection can be 

calculated without loading any data.  
 

Detector trajectory is an x vs. y 1d plot. Both x and y are chosen from droplist. If None is chosen, the 

detector group number is used. Extra thickness can be used to restrict the range of data in other 

dimension. If no ranges are set for x, y, and extra thickness, the default is to show all possible data. 

The following is an example in diffuse scattering mode. The dark yellow lines denote the aluminum 

powder line. 
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Oplot Trajectories button is used to overplot the trajectory in the current plot window. The button is 

insensitive until the projection is calculated and in certain sample modes. 
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