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Powder Sample
1. Change the sample type to Powder. Select the data files, and press Load Data button.

Sample Powder |
ERebin Size |1 -
Intensity Label |Ir|'uans'rt3,I (@, units)
Tile Label |
Legend Label |
LoadQata | I
g

2. Choose the viewing axes, and press Calculate Projection button.

Viewing Axes: |
Label

ul i ~||a

u2 |EﬂEI'Q}' le swap Cal-:ulatq\groje-:tinns |

3. Press Plot Slice button to view the color contour plot of the intensity over the chosen viewing axes,
or Surf Slice to view the 3D surface plot.

Slice | Cut Detector Trajectory

horizontal range 13 0 to: |25 step 0.015
vertical range E -1 to: |25 step
intensity range 0 to: |02 color map

smoothing level 1 shading| Gouraud % | BAINBOWY w

[ P|ot[‘§&][ Surf Slice

The plot will look like the following, which is a superfluid liquid He4 roton spectrum.
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4. Choose the cutting axis, and press Plot Cut to plot the cut.

Slice | Cut Detector Trajectory
along | E | from: |0 to: |2 step
thickness range I 0 to: |25 symbol magenta | W
y | Intensity + | range |0 to: |0.05 circle + | solid w
At [ Pqdgat ][ OplotCut

The plot will look like the following.
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Single Crystal Sample
1. Change the sample type to Single Crystal. Select the data files, and press Load Data button.

Drive: |F: -

@ FA200211 Sample Single Crystal

e— E Rebin Size |‘I -
X gz A . —

20021218_07.dcs.gz Intensity Label  [Intensty (arb. units)

20021218_08.dcs gz

20021219 01 des.az Tile Label |

20021219 _02 des gz

2002121903 des gz Legend Label |

20021219_04.des gz LoacjQata |

20021219 05.dcs gz b

20021219 _06.dcs.az v

2. Select the empty can files, then in Background menu, press Load Empty Can File(s).
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F Load Detecg Background File(s)

Load Time Channel Background File{s)
Load Dark Count File(s)
Set Cverall Background Rate. ..

Load Vanadium File(s)

20021220_02.dc
20021220 _03.dcs.gz

20021220_04 dcs.gz
20021220_05.dcs.gz

File Parameter WsElEis0ysM Mask OCption Window Help

BN[(=1ES

e Single Crystal |
Size |1 ﬂ
Label |I|'rtensih.r {arb. units)
bel |
Lzbel |
loadData |  Add Data
Clear Data

B[(=1[ES

Load Empty Can File(s)

Load Detector Backaground File(s)
Load Time Channel Background File{s)
Load Dark Count File(s)

Set Qverall Background Rate...

Clear Background

20021219_06.dc
200212159_07 dc
20021215_08.dc

20021220 04 des.gz
20021220 05.dcs.gz
20021220 _06.dcs.gz

e Single Crystal |
Size |1 j
Label |I|'rtensih.r {arb. units)
sbel |
lzbel |
loadData |  Add Data
Clear Data

Press Yes for empty can subtraction and OK in the dialog window for absorption correction without

filling in the size of the vanadium sample.

4. Enter the lattice parameters, crystal orientation, and the viewing axes, then press Calculate
Projection button. Psi is the angle from ki to u, with counterclockwise being the positive direction.

Unit Cell Lattice Parameters: Crystal Orientation:

af(f) |18.686 b (&) |8.032 cif) |6.146 wx (0 w [0 uz 1

a |90 By |50 T |90 VK 0 v |- vz 0

Psi 95 first angle of ki"u
Orthogonal Viewing Axes:
a” b* c* Label Fold Center  Direction
o v ok JOpP |
u2 |D ||D ||1 |||- | |D ||auto - ” swap ][ Calculatef“gajections ]

5. Choose the slice plane. Press Plot Slice button to view the color contour plot of the intensity over
the slice plane, or Surf Slice to view the 3D surface plot.

Slice |C|.rt Volume | Detector Trajectory
perp ta | [0.K.0] v | thick | | o | |
horizontal range L |D.2 | to: |1 | step
vertical range E |—D.3 | to: |3 | step
intensity range | 0 | to: | 0.1 | color map
smoothing level " shading Flat + | RaINBOW v|

[

Fit

[ PofSice | Surf Sice |




The plot will look like the following.
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6. Choose the cutting axis and thickness over the other two axes, and press Plot Cut to plot the cut.

Slice | Cut Volume || Detector Trajectory

along | E (meV) ~ | from: |0.2 to: |3 step 0.02
thickness range K to:
thickness range L 0.42 to: |057 symbal green v
y | Intensity % | range |0 to: |02 circle + | solid w

T P|q;“gm [ Oplot Cut

The plot will look like the following.
=IE]
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Intensity (abs. units)




Single Crystal Diffuse Scattering

1. Change the sample type to Diffuse Scattering Single E and choose Elastic Peak as the energy range.
Select the data files 20030415 _095.dcs.gz to 20030417 _035.dcs.gz, and press Load Data button.

Dirive: |F -

@ |F"‘-2""""1 Sample Diffuse Scattering Single E |

20030417 0274 Energy Range |Elastic Peak ﬂ
027 des.gz -

20030417_028 des.gz Intensity Label  {Intensty (arb. units)

20030417_029.dcs.gz e

20030417_030.dcs.oz tle Labe |

20030417_031.des.gz Leqend Label

20030417_032 des gz gend Lsbel |

20030417_033 des gz LoagQata |

20030417_034 des.gz by

20030417_035.des.gz

2. Enter the lattice parameters, crystal orientation, and the viewing axes, then press Calculate
Projection button. Psi is the angle from ki to u of the first file, with counterclockwise being the
positive direction.

Unit Cell Lattice Parameters: Crystal Orientation:
a |A} 3735 b |,.'-‘\} 3735 c |,.'-\} 3.735 X 1 uy 0 uz 0
af) |90 B¢y |50 50 VK 0 wy 1 vz 0
Psi |56.8 first andle of ki™u
Orthogonal Viewing Axes:
El b c” Label Fald
ul 1 0 0 H F]
u2 0 1 0 K [F [swap ][ Calculati\grojedions ]I

3. Press Plot Slice button to view the color contour plot of the intensity over the viewing axes, or Surf
Slice to view the 3D surface plot.

Slice | Cut Detector Trajectory
horizontal range H to: step 0035
vertical range K to: step 0.035
intensity range 0 to: |40 color  map
smoothing level 1 shading| Gouraud % | BAINBOWY w
it [ PlofSice |[ Sur Sice

The plots will look like the following.

vt E = i0ix]
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Plot Slice Surf Slice




File Type
dcs_mslice is designed to handle multiple instrument and file formats. To switch among file types, go
to File->FileType menu. If specific tools for the chosen file type are available, they are included in
File->FileTools menu. Please refer to Help->How to Add a New File Type for the procedures of
adding a new file type to the dcs_mslice program.

File Tools
File->FileTools menu contains specific tools for the current file type. This menu will be insensitive if
no tools are available.

Convert DCS Files to SPE Files
For DCS file type, Convert DCS Files to SPE Format button in the File->FileTools menu starts a
stand-alone application to convert DCS files into ASCII SPE format which can be processed by
MATLAB Mslice or other programs.

# Convert DCS data files to SPE format
File Mask Option Help

DCS file directory SPE file directory
COverall background rate
Drive: |F:\ - (cts/hr/det): Drive: O -
0
@ ||'_3-"'-2|3'D:"DE Associated emor: @ |C3"'¢|TII3

20070701_001.dcs.az
20070701_002.dcs.az
20070701_003.dcs.az

20070701_D04.des gz

20070701_005.dcs gz
20070701 006 des.gz
20070701_007 des.gz
20070701_008 des gz
20070701_009 des .z
20070701_010.des gz
20070701_011 des gz

o
Energy binning size:
2 -

Load BG
Load V

Convert

20070701_001.spe
20070701_002.spe

20070701 _003.spe

Col %ine s3ve a3 |Con1bine.spe

Choose one or more DCS *.dcs or *.dcs.gz files in the DCS file directory, press Convert button to
convert them into *.spe files. The converted files will have the same names as the DCS files except for
the file extension and they are saved in the SPE file directory.

To combine two or more DCS files, choose them in the DCS file directory, then press Combine
button. The name of the combined SPE file can be specified in the save as: textbox. If no name is
given, the default is ‘combine.spe’.

Overall background rate and Associated error are used to apply an overall background rate to all
the detectors. The background will be subtracted in Convert and Combine operations.

Energy binning size is used to rebin the time channel to reduce the size of data.

Load BG button is used to load background files, which will be subtracted in Convert and Combine
operations. There are two types of backgrounds: empty can and detector dependent energy gain side
background. The types can be changed in Option->BG File Type. Once the background file is loaded,
they will stay in the memory until Clear BG button is pressed. The Clear BG button will be sensitive
only when a background file has been loaded.

Load V button is used to load vanadium files, which will be used to calculate the detector efficiencies.
If the empty can background data are present, they can be subtracted from the vanadium data. The
detector efficiencies are divided from data in Convert and Combine operation. Once the vanadium
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file is loaded, the detector efficiencies will stay in the memory until Clear V button is pressed. The
Clear V button will be sensitive only when a vanadium file has been loaded.

Both background files and vanadium files are selected in the DCS file directory.

Detectors can be masked in various ways in the Mask menu. Once set, the mask will stay in the
memory until Mask->Clear the mask is pressed.

The data files can be saved as either single crystal or powder sample by choosing the corresponding
sample type in the Option->Sample Type menu. With the choice of powder sample, detectors with
the same two theta angle will be combined. The default is powder.

Detector configuration file (*.phx) can be created during file conversion by choosing the Yes option in
Option->Create Detector File. The default is No.

The other options in the option menu are the same as those in the mslice option menu.

Plot Single Crystal Alignment Files

This is one tool specific for DCS and WAND files. It allows one to easily plot the single crystal
alignment files and fit the peak with a Gaussian function. The detector numbers corresponding to the
Bragg peak need to be specified. The time channels can be all, elastic(time channels covering the
whole elastic peak) or specified energy range. It also provides the capability of plotting temperature
dependence of intensities in specified detectors and time channels.

<A DCS Single Crystal Alignment Utility
File Option Tools

Dve: Wy =] Det. Number

: det=458:464¢(<2th>=65.50"), tchan=elastic
Specify -

@ H200308 Time Channel
st z Elastic -

Keads

Rotation hd

Load Data

[:*]
=]
(=]

Gauss Fit

Neutron Counts/66 Secs
o
-
(=]

Save Plot

| smmhza | 51.0 515 520 525 53.0 535
Print Rotation (")

Exit

[=]

File Option Tools

Dve: A =) Det. Number
- det=131:913(<2th>=72.31"), E=[0.3,1.2]meV
[Soecty <]
Time Channel

Keads

Temperature  «

Load Data
Gauss Fit

Neutron Counts/1800 Secs

Save Flot
Save Data

Print

Exit




Save Slice Data

File->Save Slice Data As menu allows you to save the current slice data in four formats: DAVE file,
SPE file, (intensity, err, X, y) 4-column ascii file, or (X, y, intensity, err) matrix file. The following is
an example of the matrix file for a 3x4 matrix data.

34 ;nxX ny

0.2 :Xdat
0.4
0.5

-1 ;ydat
0
1
2

0.10 0.22 0.33 ;intensity
0.11 0.40 0.65
0.12 -2.80 -1.20
0.13 3.12 0.00

0.01 0.02 0.04 .error bar
0.02 0.10 0.11
0.02 0.75 0.02
0.03 0.25 -1.00

The slice data are exactly the same as the data shown if Plot Slice button is pressed except that there is
no smoothing of the data. -1 in the error bar signifies missing data in the grid. A filler of -1e20 is also
used to represent the missing data intensity. Note that the error bar is not passed to the slice plot.

Save Cut Data

File->Save Cut Data As menu allows you to save the current cut data in two formats: (x, y, yerr) 3-
column ascii file, or DAVE binary file.

The cut data are exactly the same as the data shown if Plot Cut button is pressed.

Save Projection

File->Save Projection As menu allows you to save the whole projection data in a multi-column ascii
text format. The first line is the label of each column of data.

Execute Script File

A script file should contain executable IDL statements. The following is a list of operations that can
be included in the script file.

self->script,'load_parameter’,directory=directory,filename=filename ;load parameter file
self->script,'load_emptycan',directory=directory,filename=filename,combine=combine,$
angwidth=angwidth ;load empty can file

; The combine and angwidth keywords are used in the diffuse scattering. If combine is set,

;files with orientation angle within angwidth will be combined. If angwidth is not supplied,

;the default self.angwidth is used.
self->script,'load_data',directory=directory,filename=filename,eief=eief  ;load data file



self->script,'calc_projection’,temperature=temperature,dwu2=dwu?2 ;calculate projection
; The temperature keyword is used as the sample temperature for certain intensity types.
‘The dwu2 keyword is used for u? in the Debye-Waller correction for certain intensity types.
; The default value for dwu? is 0.
self->script,'save_cut',directory=directory,filename=filename,xye=xye,dave=dave
;save cut to a file
self->script,'save_slice',directory=directory,filename=filename ,dave=dave,iexy=iexy,spe=spe,$
xyie=xyie,smooth=smooth,filler=filler ;save slice to a file
;The smooth keyword is used for smoothing the data. The default value is 0.
;The filler keyword is used to represent the empty grid data. The default value is -1e20.
self->script,'save_volume',directory=directory,filename=filename ,smooth=smooth,filler=filler
;save volume to a text file

self->script,'keep_current_plot' ;keep the current plot
self->script,'plot_cut',overplot=overplot,title=title,legend=legend ;plot the cut
self->script,'plot_slice’,surfplot=surfplot,title=title ;plot the slice
self->script,'plot_volume' title=title ;plot the volume data

In 'save_cut' script, set the xye keyword to save as a text file. In 'save_slice’ script, set one of the spe,
iexy, and xyie keywords to save as a text file. The file formats are described in the save slice data
section.

Save and Load Parameters

To save the current settings in the main window, click the Parameter-> Save Parameters button. A
file selection window will pop up. The default extension of saved file is *.prm. If no file name is
entered or selected, no action is taken.

To load a previously saved parameter file, click the Parameter->Load Parameters button. A file
selection window will pop up. All the parameters shown in the main window plus some options will
be restored. However, previous data and projection are not loaded.

Change Self-Shielding Factor
The self-shielding factor is used in background subtraction according to the following equations:

| = ly-ssfactor*l,,
Err = \JErm,? + (ssfactor * Err,)? .

Change Smoothing Kernel
The smooth kernel for smoothing the 2D slice data can be changed in the Parameter menu. The
default kernel is [[0.1,0.2,0.1],[0.2,0.8,0.2],[0.1,0.2,0.1]]. An error will be given if the entered matrix
IS not symmetric.

Change Binning Threshold

The binning threshold (f) is a factor that is used to remove bins that have too few number of data in
them. Only bins that have at least F*NMAX number of data will be plotted. NMAX is the maximum
number of data in a single bin. The default is f=0, which will include all data in the binning. This
factor will be reset to O every time a new file is loaded.

10



Change Empty Can File Orientation Angle Binning Width

In diffuse scattering modes, the empty can files with different orientation angles can be combined.
Files with orientation angles within the orientation angle binning width will be combined. Setting the
binning width to a negative value will cause all files to be combined into one angle. If the binning
width is nonzero, a dialog window asking for confirmation of the combination will appear when
loading the empty can files.

Set Data and Working Directory
Set Data Directory in the Parameter menu will change the data directory to a new one.

Set Working Directory in the Parameter menu will change the working directory to a new one. The
working directory is used as the default directory in saving files.

Load Empty Can File(s)

To load an empty can file, use the upper left file locator to select the empty can file(s). Then press the
Background->Load Empty Can File(s) button. The empty can data will stay in the memory until
the Background->Clear Background is pressed. The empty can data will be subtracted in projection
calculation. The intensity (I) and error (Err) are calculated as follow:

| = l;-ssfactor*l,

Err = \/Err,? + (ssfactor* Err,)?

where ssfactor is the average self-shielding factor. In diffuse scattering mode, the background file data
are accompanied by orientation angle information, and the background data with the closest
orientation angle is subtracted during projection calculation. In the other modes, the background files
are combined into one angle even if the actual angles are different. One can choose to combine the
background files in diffuse scattering mode if the orientation angle binning width is nonzero. The
binning width can be changed in Parameter->Change Empty Can File Orientation Angle Binning
Width. To combine all angles, set the binning width to a negative number.

Load Detector Background File(s)

This operation calculates the supposedly flat background from the specified background files. The
result is an array with the size of the number of detectors. An energy range will be asked, which is
used to locate the flat background. An example will be using a very low temperature measurement and
an energy range in the energy gain side, where no scattering would be expected. The background data
will stay in the memory until Background->Clear Background is pressed. The background will be
subtracted in projection calculation.

Load Time Channel Background File(s)

This operation calculates the background of certain time channels averaged over a given 2theta range
from the specified background files. The result is an array with the size of the number of time
channels in the given energy range. The energy range and two theta range will be asked, which are
used to locate the background. The background data will stay in the memory until Background-
>Clear Background is pressed. In projection calculation, the background in the relative time
channels will subtracted from the data.
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Load Dark Count File(s)

This operation loads a shutter closed dark count file. Use Background->Clear Background to clear
it from the memory. This operation currently is only functional for DCS file type. If empty can data
are present, the dark counts will be subtracted from them also. Dark count data and the overall
background rate reside in the same memory.

Set Overall Background Rate

The Set Overall Background Rate button in the Background menu is used to input the overall
background rate in counts/hour/detector. The value is then adjusted accordingly to be subtracted from
DCS data in projection calculation. There is no error bar handling in this process. Use Background-
>Clear Background to clear it from the memory. This operation currently is only allowed for DCS
file type. If empty can data are present, the overall background rate will be subtracted from them also.

Clear Background

Background->Clear Background button is used to clear the background data, empty can data, and/or
overall background rate from memory. To take effect, projection needs to be recalculated.

Load Vanadium File(s)

To calculate the detector efficiency factor of the spectrometer, first highlight the vanadium file using
the upper left file locator, then press the Load Vanadium File(s) button in the Background menu. If
the empty can data are present when this operation is carried out, they can be subtracted from the
vanadium data in the first two sample types. The Debye-Waller factor will be calculated if the
temperature is given. One can choose to skip this calculation. The absorption of the vanadium is taken
into account if the dimensions of the annular vanadium sample are given. Press OK button without
giving the dimensions will skip the absorption calculation. The detector efficiency factor is calculated
as proportional to the integrated intensity of the elastic peak in each detector. This factor is divided
from the raw data every time the projection is calculated. However, the raw data and the projection
data are stored differently. Use Background->Clear Vanadium to clear the detector efficiency factor
from memory.

Clear Vanadium

Background->Clear Vanadium button is used to clear the detector efficiency factor from memory.
To take effect, projection needs to be recalculated.

DCS Mask

There are three detector banks in the DCS instrument, each of which can be masked. There is also a
Mask Negative Angle Detectors option to mask the small amount of detectors on the west side. As
for all masking operation, the mask takes effect when projection is calculated.

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button.

Set Your Own Mask

To mask arbitrary detectors, press the Set Mask in the Mask->Set Mask menu. The detector number
starts from 0. The mask takes effect when projection is calculated.

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button.
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Plot Mask

The Plot Mask in the Mask->Set Mask menu starts an interactive masking tool. You can read the
help information in that tool to learn how to use it to mask detectors. This function is available only
when data are loaded. The mask takes effect when projection is calculated.

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button.

Mask Bragg Peaks

To automatically mask the detectors where the Bragg peaks occur, press the Mask->Set Mask-
>Mask Bragg Peaks menu button. An interactive plot mask window will appear to allow
modifications. This function is available only when data are loaded. The mask takes effect when
projection is calculated.

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button.

Save and Read Mask File
The detector masks can be saved in a text file by pressing the Save Mask File in the Mask menu.

The index numbers of detectors to be masked can also be read from a text file. The numbers should be
separated by space or comma, and can be in multiple lines. The detector number starts from either 0 or
1. The mask takes effect when projection is calculated.

Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button.

Instrument Geometry

There are two instrument geometries, Direct for fixed Ei instruments and Inverse for fixed Ef
instruments. For a given instrument, this option may not be available.

Intensity Type
Use Option->View Intensity As button to choose the intensity type as one of the following:

S(Q,omega) --- a factor of (ki/kf)* is applied to the normalized intensity,
Symmetrized S(Q,omega) --- a factor of exp(-E/2kgT)*(ki/kf)* is applied to the normalized intensity,
d2(sigma)/d(Omega)d(Ef) --- a factor of (ki/kf)* is applied to the normalized intensity,

Chi(Q,omega) --- a factor of [1-exp(-E/ksT)] (ki/kf)* is applied to the intensity,
GDOS --- a factor of [1-exp(-E/ksT)] (ki/kf)* *E/Q"2 is applied to the intensity,
VDOS --- a factor of [1-exp(-E/kgT)] (ki/kf)* *E*sin(2th)/(Qmax4-Qmin™4) is

applied to the intensity,
Unadjusted by ki/kf factor --- no ki/kf factor is applied to the normalized intensity.

The option E-Integrated Intensity in the Option->View Intensity As menu will cause the following
calculation to be carried out in plotting cuts and slices:

Z IAw
| = AE,
ZAa)
where Aw is the energy width for the corresponding time channels, and AE is the proper energy

range, for example the energy thickness in a Q-cut, or the energy binning steps. A warning message
will be given if this option is on when starting dcs_mslice program.
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Binning Method

Two binning methods, average and sum, can be chosen from the Option->Binning Method menu
button. The average or sum of the intensities in each bin is calculated respectively in the two methods.
The binning method is applied in rebinning time channel according to E Rebin Size for powder and
single crystal mode, and rebinning data in displaying slices and cuts.

Option->Binning Method->Constant Intervals menu provides the option of creating binned data at
constant interval. If the option is No, then averaged values will be the output.

Option->Binning Method->Use External Binning Library menu provides the option of using or
disabling the external binning library. If enabled, the external binning library is used when binning
steps are specified. Using the external binning library is much faster than without. However, you can
disable it if the external library is not properly installed.

Monitor Count

This only affects DCS file type. There are two options to calculate the monitor count: sum of beam
monitor counts or the integrated intensity of the beam monitor counts after fitted by a Gaussian. The
option is set in Option->Monitor Count. The monitor count is used to normalize data in loading
DCS files. The monitor type can be selected by Option->Monitor Count->DCS Monitor Choice.
BM1 is the monitor at the guide exit, and FCO is the upstream monitor before the choppers. BML1 is
the default monitor, and only when it is selected will sum and integrated intensity option matter.

Absorption Correction

Absorption corrections for cylindrical, annular, and spherical sample geometries are implemented in
the program. Go to Option->Absorption Correction menu to set the option. The absorption
correction factor for every angle and energy is calculated using 360 (or 6480 for sphere) uniform
sampling points on the sample cross section. Instead of calculating the correction for 913 detectors
and 1000 time channels, which is time consuming, interpolation from 100 angles and 100 energies can
be used. The correction is for equatorial scattering only. The effect of DCS radial collimator is not
taken into account in the calculation.

Viewing Axis Type
For single crystal and diffuse scattering type, there are two options of viewing axis: orthogonal and

arbitrary. They can be set in Option->Viewing Axis. If orthogonal option is chosen, the viewing axes
given must be orthogonal to each other.

Allow Extra Viewing Axis

In single crystal and diffuse scattering modes, by default only two viewing axes plus the energy
(except for diffuse scattering single energy) are available for projection. To have a third viewing axis,
set Option->Viewing Axis->Allow Extra Viewing Axis on. The orthogonality of the viewing axes
follows the Option->Viewing Axis setting. The projection needs to be recalculated.

Show Powder Line

In diffuse scattering mode, Al, Cu, stainless steel, or specified powder lines can be overplotted to the
intensity contour plots or detector trajectories (when the viewing axes are x and y axis). To do this,
select the Al, Cu, or Stainless Steel option in Option->Show Powder Line menu. Arbitrary Q values
can also be specified. The projection needs to be recalculated to have the option in effect.
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Elastic Peak Position Adjustment

The elastic peak position adjustment operation in Option->Elastic Peak Position Adjustment rotates
the data so that the maximum intensity(Automatic) or the time channel of specified energy(Specify)
will be shifted to E=0. The energy values will not be changed. If Check the First File Only option is
on, only the first file will be examined for how many time channels need to be shifted. After changing
this option, you need to reload the data files.

Plot Window Background Color

The background color of the plot windows can be either black or white, selected in Option->Plot
Window Background Color.

User Macro/Function/Procedure

To interact with the projected data, use the Option->User Macro/Function/Procedure menu. Either
multiple strings of command macros or a string of call to user defined IDL function or procedure can
be specified.

The user macro should be executable IDL statements. Multiple statements can be in a single line
separated by “&”. The user function and user procedure can be defined in any way. Only the call to
the function or procedure needs to be entered in the menu dialog window. A list of the internal
variables is shown in the dialog window. The array dimensions of the variables should not be altered.
The user functions are executed during projection calculation.

Here are some of the available variables:

gty  ---intensity.

err  ---error bar.

eief  --- Ei for direct geometry and Ef for inverse geometry.

Q --- wave vector transfer in A™. A vector in single crystal mode. Qx is along ki; Qx and Qy
are in the scattering plane; Qz is pointing upward.

Qv  --- wave vector projected onto the viewing axes, in corresponding reciprocal lattice unit.

en --- energy transfer.

det_tt --- detector 26 angle.

Tip 1: Specifying the user function after the projection has been calculated will enable the array
dimensions of the available variables being shown. The projection needs to be recalculated after the
user function specification.

Tip 2: To do a model calculation, generate gty and err so that they have the same array dimensions as
Q in powder mode, or an array dimension of [D2, D3, ...] in single crystal mode, where Qv has a
dimension of [D1, D2, D3, ...].

Dark Angle Correction

In diffuse scattering measurement, if the incident neutron intensity is affected by the dark angle of the
cryostat or magnet, a simple dark angle correction can be applied by assuming a constant scattering
cross section (such as elastic incoherent scattering or vanadium) in specified energy transfer and two
theta range. This option is in Option->Dark Angle Correction. You can choose the same data files
for this purpose. The projection needs to be calculated to have the option in effect. After projection
calculation, the overall intensity factor for each corresponding file is given the value of Imax/I, where
| is the total neutron counts in the specified E and two theta range.
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E-Dependent Detector Efficiency Correction

The energy dependent detector efficiency correction to the intensity can be applied to the data in
projection calculation. To set this option on and off, press the Option->E-Dependent Detector
Efficiency Correction button. When the program started, this option is on.

Hide Error Bar

Choose Option->Hide Error Bar to prevent the error bars been shown in plotting cuts. However, the
error bar will still be present in fitting the cuts.

View Spurion Caused by Detector

Option->View Spurion Caused by Detector option will cause the program to calculate spurious
scatterings by the detector wall of all elastic signals. If spurion exists, the program will use the current
settings to plot a slice.

Check Bitflip Error

Right-click to the left of Load Data button to show the popup menu and this option. Use this option
to enable or disable the bitflip error checking during DCS data file loading.

Preserve Negative 2theta Angle Value

Right-click to the left of Load Data button to show the popup menu and this option. In powder mode,
after the projection is calculated, only the absolute values of the 2theta angles are saved, unless the
Preserve Negative 2theta Angle Value option is turned on. The projection needs to be recalculated to
have the new option in effect.

Detector 2theta Correction

Right-click to the left of Load Data button to show the popup menu and this option. Use this option
to enable or disable the 2theta correction due to the length of the detectors or some other reasons. This
option may not be available for some instruments.

Allow Two Sets of Empty Can Files

Right-click to the left of Load Data button to show the popup menu and this option. Use this option
to allow or disallow two sets of empty can files. If two sets are allowed, the empty can subtraction is
as follows:

I = Isamp|e = szactor*(factorl*Iemptycanl + factorz*lemptycanz),

where ssfactor is the self-shielding factor, and factor; and factor, are extra factors that can be changed
in Parameter->Change 2-Set Empty Can Factors. The handling of the additional set of empty can
files is the same as that of the first set.

Show Dark Angle Trajectory

Right-click to the left of Load Data button to show the popup menu and this option. Use this option
to show the trajectory of a dark angle of a cryostat in experiment planning. With this option on, and in
diffuse scattering modes, when you calculate the projections, in the dialog window for Psi range, there
is an entry for the dark angle position. The dark angle position is with respect to the crystal orientation
axis u, with counterclockwise rotation being positive. The plot shows an example where the dark
angle is along v axis.
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Courterclockwise rotation is positive.

Hiding Part of the Window

The projection and the display frame of the window can be hidden by using the corresponding option
in Window menu. This can be quite useful if the size of the window is larger than the screen. The
following snapshot is an example.
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Close All Plot Windows
To close all plot windows, simply press Window->Close All Plot Windows button.
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Load Data
To load data files, use the top left file locator to select one or more files. Press Load Data button to
load the data. An error will be given if no file is highlighted. For DCS data, the data will be
normalized by the monitor counts of beam monitor 1 if shutter is open.

For powder and single crystal sample type, the files will be combined. For diffuse scattering sample
type, files are not combined, and energy range needs to be specified beforehand. For file types other
than DCS, weights are required for proper data summation.

The loaded data will not be modified by the program until new data file is loaded or added, or the
sample type is changed to or from diffuse scattering types. Press Clear Data button to remove the
data from memory.
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20030807_010dcs.qz s -
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90030807 016 des gz LoaciData |
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20030207 018 des gz v

Tip 1: For supported file types, move the cursor over the highlighted files and right click to view the
file information such as comment, wavelength, temperature, etc.

Tip 2: Move the cursor to the left of the Load Data button and right click to access the extra options
in the popup menu and view a list of the current settings of parameters.

Add Data
The Add Data button will be activated when data has been loaded.

Select the data files to be added by the upper left file locator. Then press the Add Data button. An
error will be given if the file selected and the existing data are of different type. The criteria for DCS
files are wavelength, master speed, speed ratio, resolution mode, and tsdmin.

For powder and single crystal data, the data are added to existing data; for diffuse scattering sample
types, the data are appended to the existing data. The algorithm for computing added intensity(l) and
error(Err) with weights(W) taken into account is as follows:

I3 = (|1*W1+|2*W2)/(W1+W2),

Errs = J(Err, *W,)? + (Err, *W,)? /(W, +W,),

W3 =W;+Wos.

Clear Data

Press Clear Data to clear from memory the loaded data and calculated projection data if existed. This
operation is useful in planning experiments.

Sample Type
There are four sample types (more accurately modes of operation): powder, single crystal, diffuse
scattering singe E, and diffuse scattering multiple E.
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For powder mode, two viewing axes need to be specified. In the projection calculation, detectors with
the same two-theta angle are combined. The data is plotted as 2D intensity color map on the plane
defined by the viewing axes. The data can also be cut along one of the two viewing axes with
restrictions on the other axis, and plotted as 1d plot.

For single crystal and diffuse scattering modes, lattice parameters, crystal orientation, and viewing
axes need to be given to enable proper projection calculation. By default two viewing axes are
available. To enable a third viewing axis, check Option->Allow Extra Viewing Axis. Except for
diffuse scattering single E mode, the energy is also present as one axis. The data is plotted as 2D
intensity color map on the plane defined by two of the axes (including the viewing axes and the
energy if available). The other axes are used to restrict the slice range. The data can also be cut along
one of the viewing axes with restrictions on the other axes, and plotted as a 1d plot.

The difference between diffuse scattering single E mode and multiple E mode is the treatment of the
energy dimension. In single E mode, data within the specified energy range are combined to a single
energy to save computer memory, while in multiple E mode, the data are not combined, which could
sometimes lead to memory problem. If error occurs due to lack of computer memory, the solution is to
reduce the specified energy range, increase the E-rebin size, or switch to single E mode.

When the sample type is changed, the projection data is cleared and need to be recalculated before any
plots can be made. The raw data is still stored in the memory if the change is between powder and
single crystal type.

Lattice Parameters

For single crystal and diffuse scattering sample types, the direct lattice parameters of the unit cell are
specified by a, b, ¢, a, B, and y. a is the angle between b and c, B is the angle between ¢ and a, and y
is the angle between a and b. An error will be given during projection calculation if any one of the six
lattice parameters is missing.

Crystal Orientation

For single crystal and diffuse scattering sample types, the crystal orientation with respect to the
spectrometer is defined by two reciprocal crystal axes (u & V) in the principal scattering plane of the
spectrometer and one angle (Psi), which uniquely identifies the rotation of the crystal in this plane.

v

Psi

¥
k;

(ux, uy, uz) and (vx, vy, vz) specifies the two reciprocal crystal axes. u x v should point to the
vertically upward direction. Psi is the angle between u and ki, and is positive if ki x u is pointing to
the vertically upward direction. For DCS file type, it should be the same as DCS A2 angle if A2=0
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when ki//u. For diffuse scattering, Psi is the angle for the first file.

An error will be given in projection calculation if any value of u, v, or Psi is not set.

Viewing Axes
Powder
The viewing axes for powder are two axes out of (Energy, |Q|, 2Theta, and Det Group Number). They
can be specified from the droplists. The labels of the viewing axes are used as corresponding axes

titles in the 2d plots. The Most commonly used set of viewing axes for powder sample is ul=|Q| and
u2=Energy.

Single Crystal and Diffuse Scattering

The viewing axes for single crystal and diffuse scattering are wave vector directions. They must be
orthogonal if the orthogonal option is chosen for the viewing axis type. An example is :

ul=[100] ;a*
u2=[010] ;b*

An error will be given in projection calculation if any value of the viewing axes is not given or the
axes are not orthogonal when required.

The viewing axes can be folded around a folding center. The auto folding direction is to the side with
larger range. Multiple folding centers can be specified in a text box separated by space or comma.
Cliking on the direction droplist with multiple folding centers specified will bring up a dialog window
for the multiple folding directions. The folding is done in the same order that the centers are specified.
The projection needs to be recalculated if any of the folding selections is changed.

Energy Rebin

To reduce the amount of data being processed and plotted, the raw data can be rebinned in the
projection calculation for powder, single crystal, and diffuse scattering multiple E modes. Time
channels are binned according to the size specified in the E Rebin Size textbox. No action is taken if
the E rebin size is less than one or absent. The rebinning can be either average or sum according to the
specified binning method. In powder and single crystal modes, the raw data is not affected by the
rebinning, therefore changing the rebin size requires only the projection to be recalculated. In diffuse
scattering multiple E mode, the raw data are rebinned, therefore changing the rebin size requires
reloading the data.

Calculate Projection

Press Calculate Projections button to project the raw data into viewing axes. Detector masks and
detector efficiency factors are applied if they are present. The background will also be subtracted if
they have been previously loaded. Intensity data are also rebinned if E rebin size is greater than 1 for
powder and single crystal modes. The intensity will be calculated as one of several options chosen in
Option->View Intensity As menu. Energy dependent detector efficiency will be calculated if the
option is set. Absorption correction factors will be calculated and multiplied to the intensity if so
chosen. User function will also be executed if specified. The projected data and the raw data are stored
differently, i.e., the raw data are not changed by this calculation. If no data has been loaded, the
program will prompt for incident neutron energy Ei to calculate detector trajectories.
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For powder mode, detectors with the same 2theta angle will be combined.
For diffuse scattering modes, data with the same sample orientation angles will be combined.

For single crystal and diffuse scattering modes, an error message will be given if any value of the
lattice parameter, crystal orientation, and viewing axes is not given, or if the viewing axes are not
orthogonal when required.

Tip 1: For NXSPE file type, clearing data after loading an existing data file will save the detector
information, which allows for the projection calculation.

Intensity Label

The intensity label is used as the axis title for intensity in plots. If not given, the default is Intensity.
IDL formatting codes are supported.

Title Label

The title label is used as title in plots. IDL formatting codes are supported. It is set to the comment of
a data file after the file is loaded. The plot title can be easily modified in the plot window.

Legend Label

The legend label is used as the legend in plotting 1D cuts. For DCS files, it is set to the last word of
the comment of the data file after it is loaded. The plot legend can be easily modified in the plot
window.

2D Slice Plot

The intensity data projected into two viewing axes can be plotted as color contour plot by pressing the
Plot Slice button.

In Single Crystal and Diffuse Scattering modes, the axis perpendicular to the slice plane is chosen
from the perp to droplist, which includes the viewing axes and the energy(except Diffuse Scattering
Single E mode). The choice of the perpendicular axis automatically defines the next two axes as the
slice plane axes, and the horizontal and vertical label will change accordingly. The axes left will be
used to further define the thickness of the slice.

Data can be rebinned by specifying the horizontal and/or vertical step. If not specified, the default
binning size is 1000 except for energy data. The binning algorithm is as follows: a grid of bins of size
xstep X ystep is constructed with the lower left corner at (xmin-xstep/2, ymin-ystep/2) and not
exceeding xmax+xstep/2 along x and ymax+ystep/2 along y. The x and y values for each bin are
calculated by taking the average of the x and y values of all the data in that bin, and the intensity is the
average or sum of all the data in that bin according to the specified binning method. The limits are
inclusive to the left and exclusive to the right.

The grid can be smoothed by choosing a nonzero Smoothing level. The default smoothing kernel is

0.1 02 0.1
0.2 08 0.2
0.1 02 0.1.

The kernel can be changed in the Parameter menu.

The color map of the contour plot can be chosen from the color map droplist. The names are the same

21



as the predefined IDL color table names.

Two types of shading are available: Flat and Gouraud.

Flat: The color has a constant intensity for each face of the surface, based on the normal vector.
Gouraud: The colors are interpolated between vertices, and then along scan lines from each of the
edge intensities.

The 2D data can also be plotted as color surface plots by pressing the Surf Slice button.
Tip 1: Specify the horizontal and vertical range to reduce the amount of data and speed up the plotting.

Tip 2: If the energy step is not specified, the original energies corresponding to the time channels are
used. This will prevent the energy values from being changed by the binning process.

Tip 3: For a large dataset, the binning will usually be much faster with the steps specified.

1D Cut

Cuts can be made along one of the viewing axes with integration over the other one or two viewing
axes. Use along droplist to select the x axis, and y droplist to select the y axis. The plotted data are the
average or summed values over the integrated volume according to the specified binning method.

X and y range, integration volume (thickness) can be specified by the from: and to: textboxes. Data
can also be rebinned by specifying the cut step. The x-range is divided into bins of length step starting
at xmin-step/2 and not exceeding xmax+step/2. The x and y value for each bin is calculated by taking
the simple average of the x and y values of all data in that bin, where the limits are inclusive to the left
and exclusive to the right.

Plot symbols can be specified by the color, symbol style, and line style droplists. White color will be
switched to black when the figure is printed or saved as a file. Press Plot Cut to plot the cut in the
current plot window, or press Oplot Cut to overplot the cut in the current plot window.

The cut data can also be sent to the Peak Analysis (PAN) program for fitting. To do this, simply press
the Fit button.

Tip 1: If the cut is along energy and the step is not specified, the original energies corresponding to
the time channels are used. This will prevent the energy values from being changed by the binning
process.

Tip 2: For a large dataset, the binning will usually be much faster with the step specified.

3D Volume Plot

A volume plot can be made if the number of viewing axes (including the energy) is more than two.
Proper steps need to be specified to achieve the ideal result. There are two interpolation methods:
nearest neighbor and trilinear. The trilinear method gives a smoother look, but slower in rendering.

Fitting Data
Both the slice data and cut data can be sent to PAN program for fitting by pressing the Fit button.

Plot Trajectories

The Plot Trajectories button is insensitive until projection is calculated. The projection can be
calculated without loading any data.
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Detector trajectory is an x vs. y 1d plot. Both x and y are chosen from droplist. If None is chosen, the
detector group number is used. Z can be used to restrict the range of data in extra dimension. If no
ranges are set for x, y, and z, the default is to show all possible data. The following is an example in
diffuse scattering mode. The color lines denote the aluminum powder line.

Oplot Trajectories
Oplot Trajectories button is used to overplot the trajectory in the current plot window. The button is
insensitive until the projection is calculated and in certain sample modes. The projection can be
calculated without loading any data.
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